fixin (fixin) wrote,
fixin
fixin

Возврат услуг в ут



9.1.1     Возврат услуг в документе «Возврат покупателя» (УТ 10.3)


Почему то в УТ запрещено в документе возврат от покупателя оформлять возврат услуг, хотя в Рознице это возможно.


Чтобы исправить ситуацию, в модуле документа комментируем строку:


     //УправлениеЗапасами.ПроверитьЧтоНетУслуг(ЭтотОбъект, "Товары", ТаблицаПоТоварам, Отказ, Заголовок);


В конце процедуры ОбработкаПроведения удаляем лишние проводки по остаткам товаров:


     //Удаляем лишние движения


     МассивРегистров = Новый Массив();


     МассивРегистров.Добавить("ТоварыВРознице");


     МассивРегистров.Добавить("ТоварыНаСкладах");


     МассивРегистров.Добавить("ТоварыОрганизаций");


     Для Каждого ИмяРегистра Из МассивРегистров Цикл


          НЗ = Движения[ИмяРегистра];


          Всего = НЗ.Количество();


          Для Инд = 1 По Всего Цикл


                МЗ = НЗ [Всего - Инд];


                Если МЗ.Номенклатура.Услуга Тогда


                     НЗ.Удалить(МЗ); //Удаляем лишние движения


                КонецЕсли;


          КонецЦикла;


     КонецЦикла;


Этого достаточно, чтобы услуги нормально возвращались.

Tags:
Subscribe

  • Искусство NEXT

    Одну из полезных вещей, которых я усвоил на РМЭС – это то, что не нужно циклиться на давно знакомых телках. С них выхлопа ноль. Познакомился,…

  • Соседка в электричке

    Утром 11 февраля электричка, как обычно, была переполнена. Я едва залез в тамбур, где людская масса прижала меня к молодой высокой соседке. Одна моя…

  • Простой тест на призвание.

    Задам два вопроса, которые покажут, насколько вы на своем месте на работе (в деле).

promo fixin december 31, 2037 16:57 1420
Buy for 30 tokens
UPD: Друзья, в августе 2019 года блог переехал на http://fixinchik.ru. Welcome! Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект "…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 0 comments