fixin (fixin) wrote,
fixin
fixin

Возврат услуг в ут



9.1.1     Возврат услуг в документе «Возврат покупателя» (УТ 10.3)


Почему то в УТ запрещено в документе возврат от покупателя оформлять возврат услуг, хотя в Рознице это возможно.


Чтобы исправить ситуацию, в модуле документа комментируем строку:


     //УправлениеЗапасами.ПроверитьЧтоНетУслуг(ЭтотОбъект, "Товары", ТаблицаПоТоварам, Отказ, Заголовок);


В конце процедуры ОбработкаПроведения удаляем лишние проводки по остаткам товаров:


     //Удаляем лишние движения


     МассивРегистров = Новый Массив();


     МассивРегистров.Добавить("ТоварыВРознице");


     МассивРегистров.Добавить("ТоварыНаСкладах");


     МассивРегистров.Добавить("ТоварыОрганизаций");


     Для Каждого ИмяРегистра Из МассивРегистров Цикл


          НЗ = Движения[ИмяРегистра];


          Всего = НЗ.Количество();


          Для Инд = 1 По Всего Цикл


                МЗ = НЗ [Всего - Инд];


                Если МЗ.Номенклатура.Услуга Тогда


                     НЗ.Удалить(МЗ); //Удаляем лишние движения


                КонецЕсли;


          КонецЦикла;


     КонецЦикла;


Этого достаточно, чтобы услуги нормально возвращались.

Tags:
Subscribe

  • Сибариты на роздыхе...

    Начал читать книгу «Предназначение» Павла Кочкина. Во введении там рассказываетс биография автора, она практически соответствует статье на…

  • Не ходи в её жопу, Ник!

    https://sharkoffart.livejournal.com/329863.html Одна женщина написала пост, что её мотивация Ника Вуйчича не мотивирует, а вгоняет в депрессию.…

  • Ли Лобанова, это не ЗОЖ

    Ли Лобанова недавно опубликовала фотку, где она отмечает какое-то очередное достижение своей жизни чит-милом в Макдональдсе, поедая гамбургеры и…

promo fixin december 31, 2037 16:57 1420
Buy for 30 tokens
UPD: Друзья, в августе 2019 года блог переехал на http://fixinchik.ru. Welcome! Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект "…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 0 comments