fixin (fixin) wrote,
fixin
fixin

Category:

Мамбо атакуэ!



На мамбе появился странный глюк - когда выдается страница "Это был спам!" (которая говорит, что пользователь, которому мы хотим отправить сообщение заблокирован как спамер), она снова и снова обновляется, так никогда и не приходя в состояние "Завершена". Видимо, скрипт пытается вернуться на предыдущую страницу, а предыдущая тоже плохая (ведь робот ходит сразу на отправку сообщения, а не через профиль пользователя).


В итоге пришлось переписывать код эмулятора, ведь ему нужно завершать загрузку страницы, даже когда она еще не загружена...


Да и сам код по отправке сообщений пришлось переписать. Не очень красиво получилось, но чтобы переписать красиво, нет ресурсов.


  ЭтоЗакрытыйПользователь = СтраницаКасаетсяЗакрытогоПользователя(Документ);
  ПрерыватьВыполнение = ложь;
  
  ОбработкаПрерыванияПользователя();
  
  Если Параметры.НеЧитается Тогда
   Документ = ПерейтиНаАдрес("
http://mamba.ru/anketa.phtml?oid=" + СокрЛП(ТекИД), Параметры);
   Если Документ <> Неопределено Тогда
    Если
     СтраницаКасаетсяЗакрытогоПользователя(Документ)
    Тогда
     ЭтоЗакрытыйПользователь = истина;
    КонецЕсли;
   КонецЕсли;
   ПрерыватьВыполнение = истина;
  КонецЕсли;
  
  Если ЭтоЗакрытыйПользователь Тогда
   Если ЗначениеЗаполнено(Параметры.КатегорияДляЗакрытых) Тогда
    пимКатегории.УстановитьКатегориюОбъекта(СтрПолучатель.ПользовательПортала, Параметры.КатегорияДляЗакрытых, истина);
    Сообщить("Удаленный пользователь найден в процессе отправки сообщения " + СтрПолучатель.ПользовательПортала + "помечен категорией: " + Параметры.КатегорияДляЗакрытых);
   КонецЕсли;
   ПрерыватьВыполнение = истина;
   Параметры.НеЧитается = истина;
  КонецЕсли;


Все платыне пользователи моей мамбопрограммы получают обновление своевременно, остальные сосут хуй ждут, пока я ее выложу на сайт.


Tags: мамбирование
Subscribe
promo fixin december 31, 2037 16:57 1415
Buy for 30 tokens
UPD: Друзья, в августе 2019 года блог переехал на http://fixinchik.ru. Welcome! Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект "…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 2 comments