fixin (fixin) wrote,
fixin
fixin

Category:

Сделал оффлайн версию своего дневника на li



Выгрузи с Live Internet свой дневник. Механизм экспорта этого сайта позволяет выгрузить записи в XML формат. Получилось около 10 файлов - по одному файлу на сезон (лето, весна, осень, зима).


Подумал, как сделать, чтобы ссылки на картинки вели на мой локальный сайт,а  не хостинг LI. Решил, что самый простой способ - открыть каждый файл и с помощью команды "Сохранить как веб-страницу полностью" вручную пересохранить страницы.


Обнаружилась проблема. Для XML-файлов IE почему то не делает сохранения в режиме "Веб-страница полностью". Попробовал в Fire Fox, там команда сохранения доступна, но сам XML отображается почему-то криво. Скачал Opera, но там тоже было что-то не то.


Написал обработку, которая просто открывает страницу (XML-файл) и сохраняет ее HTML-код в HTML-файл. Обработал все XML-файлы. Получил набор HTML-файлов со ссылками на картинки с LI. Далее каждый HTML файл открыл в IE и пересохранил. Все, получил локальные картинки. Быстро, удобно, почти без программирования.


Осталось только выложить готовый архив на сайт.


Вот внешний вид обработки:



Вот код:


Процедура КоманднаяПанель1КнопкаПерейти(Кнопка)
 ЭлементыФормы.Браузер.Navigate(Адрес); 
КонецПроцедуры


Процедура КоманднаяПанель1КнопкаСохранить(Кнопка)
 Текст = ЭлементыФормы.Браузер.Document.body.OuterHtml;
 Т = Новый ТекстовыйДокумент();
 Т.УстановитьТекст(Текст);
 Т.Записать(Файл, "windows-1251"); 
КонецПроцедуры


Процедура АдресПриИзменении(Элемент)
 Файл = СтрЗаменить(Адрес, ".xml", ".htm");
КонецПроцедуры

Tags: архивация данных, браузеры, улучшалец
Subscribe

  • Благославляю фанатов!

    Сегодня у меня был «инсайт». Он касается гавайских шаманов и их древней мудрости Хуны. Если хочешь в чем-то стать таким, как другой…

  • Плюша, писечка всё суше..

    Есть у меня молодая фанатка – Целка Плюша. Утверждает, что девственница. Я её видел на фиксофесте в Минске – ничего такая, симпатичная блондинка. За…

  • Меня читают «успешные» люди

    Как ни откроешь комментарии к моим записям, так встречаешь советы и критику от «успешных» людей. Просто удивительно, как избирательно их притягивает…

promo fixin december 31, 2037 16:57 1420
Buy for 30 tokens
UPD: Друзья, в августе 2019 года блог переехал на http://fixinchik.ru. Welcome! Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект "…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 0 comments