fixin (fixin) wrote,
fixin
fixin

Как разрешить проводить накладную будующей датой



В модуле формы накладной в процедуре ОбновлениеОтображения пишем:


 //Если РежимЗаписи = РежимЗаписиДокумента.Проведение Тогда //И Не Проведен Тогда  //Осипов 20100406
 Если Дата > КонецДня(ПолучитьОперативнуюОтметкуВремени()) Тогда
  ЭтаФорма.ИспользоватьРежимПроведения = ИспользованиеРежимаПроведения.НЕОперативный;
 Иначе
  ЭтаФорма.ИспользоватьРежимПроведения = ИспользованиеРежимаПроведения.Авто;
 КонецЕсли;
 //КонецЕсли;


Там же, в событии ПередЗаписью пишем предупреждение пользователю:


 Если РежимЗаписи = РежимЗаписиДокумента.Проведение И Дата > КонецДня(ПолучитьОперативнуюОтметкуВремени()) Тогда
  Сообщить("Документ проводится неоперативно будующей датой!!!");
 КонецЕсли;
 


Можно использовать какой-либо контроль прав, чтобы разрешать проведение будующей датой только избранным пользователям.

Tags:
Subscribe

promo fixin december 31, 2037 16:57 1417
Buy for 30 tokens
UPD: Друзья, в августе 2019 года блог переехал на http://fixinchik.ru. Welcome! Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект "…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 10 comments