fixin (fixin) wrote,
fixin
fixin

Ручной способ получить список реквизитов справочников

Была поставлена задача расписать реквизиты справочника договоров и контрагентов в двух базах, написать соответствия между ними.
Для начала нужно было получить реквизиты и их синонимы из обеих баз.
Можно было бы написать обработку, которая выводила бы данные по метаданным.
Но я поступил проще и все сделал в Экселе.
Выгрузил файл описания в Эксель.


 
Убрал объединение с ячеек.
Во вторую и третью колонку поставил формулы соответственно:
=ЕСЛИ(ЛЕВСИМВ(D2;4)="Имя:";D1;ЕСЛИ(ЛЕВСИМВ(E2;4)="Имя:";E1;""))
=ЕСЛИ(ЛЕВСИМВ(D2;4)="Имя:";ПСТР(D3;10;1000);ЕСЛИ(ЛЕВСИМВ(E2;4)="Имя:";ПСТР(E3;10;1000);""))
Формула с двумя если, т.к. реквизиты табличных частей располагаются с дополнительным отступом.
На выходе получили во второй и третьей колонке название реквизита и его синоним.
В первую колонку поставил название первой или второй базы, после сортировки получилось так:
После этого выгрузил на новый лист только значения, без формул и  отсортировал по второй колонке.
Получился список реквизитов из двух баз:


Дальше осталось с помощью автофильтра убрать строки, содержащие .Формы., .Команды., .Макеты..

Чем бы кодер не маялся, лишь бы не программировать, гыгыгы...

Tags: , Опыт Excel
Subscribe

Posts from This Journal “1С” Tag

  • Visual Basic + 1С всё?

    Вот и верь после этого Одину Эссу!? Как-то, еще на работе в Максимусе, мне понадобилось написать внешнюю компоненту для управления сканером…

  • Вы всё еще кастрируете?

    Для отладки бизнес-процессов согласования договоров прежде, чем дело дойдет до утверждения, нужно пройти длинную цепочку согласований. Чтобы не…

  • Коварный ввод на основании в УФ

    На основании документа Х можно вводить два документа А и Б. Но конкретный вид документа зависит от содержимого документа Х (вида операции). Решили…

  • Правило назначения ролей – не запрещать!

    Есть одно правило назначения ролей пользователей, которое выработано эмпирически и скорее обосновано чутьём. Нельзя делать запреты пользователям с…

  • Гуру-тест 1С: обмануть при записи

    Итак, задачка. Нужно, чтобы при записи новая версия объекта не поместилась в базу данных, но при этом не была сгенерирована ошибка или отказ. Случай…

  • Долгострои 1С

    Если вы хотите узнать, почему программисты 1С любят платформу 1С и местами ненавидят разработчиков этой платформы, то сейчас я Вам расскажу. Уже 10…

  • Ловкость рук и обработка результата запроса

    Как то я пообещал заказчику, что обработаю определенный список документов, но забыл, что эти документы были в базе с управляемыми формами. Как быть?…

  • 1С и искусственные серверные барьеры

    Заметил, что в управляемых формах 1С принуждает программистов к плохой архитектуре решений. Вкратце упомяну, что теперь большинство внешних…

  • Особенности белорусского Налогоплательщика

    Взял подработку у одного знакомого чувака из Беларуси. Платил мало (я то беру 1500 в час, а там по 800), но знакомый хороший, грех было отказывать,…

promo fixin december 28, 2020 16:57 1406
Buy for 30 tokens
Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект " Секс за Ваши". Если вы хотите написать пост обо мне или почитать, что пишут…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 12 comments