fixin (fixin) wrote,
fixin
fixin

Перемещение по строкам документа

Перемещение на предыдущую-следующую строку в 1С УФ.

Казалось бы, реализация таких простых кнопок, как переход к предыщей/следующей строке в списке табличной части обработки потребовало в управляемых формах много времени, чтобы разобраться.
 

Решение заключалось в вызове метода ПолучитьИдентификатор.

В итоге получился код:


&НаКлиенте
Процедура СледующаяСтрокаМатериалов(Команда)
 
ПереместитьСтрокуМатериалов(1);
КонецПроцедуры

&НаКлиенте
Процедура ПредыдущаяСтрокаМатериалов(Команда)
 
ПереместитьСтрокуМатериалов(-1);
КонецПроцедуры

&НаКлиенте
Процедура ПереместитьСтрокуМатериалов(Направление)
 Если
Элементы.ТЗМатериалы.ТекущиеДанные = Неопределено  Тогда
  Возврат;
 КонецЕсли;

 
ТекНомерСтроки = Элементы.ТЗМатериалы.ТекущиеДанные.НомерСтроки;
 Если
ТекНомерСтроки = Объект.ТЗМатериалы.Количество() И Направление = 1 Тогда
  Возврат;
 КонецЕсли;
 Если
ТекНомерСтроки = 1 И Направление = -1 Тогда
  Возврат;
 КонецЕсли;

 
СледующаяСтрока = Объект.ТЗМатериалы[ТекНомерСтроки - 1 + Направление];

 
Элементы.ТЗМатериалы.ТекущаяСтрока = СледующаяСтрока.ПолучитьИдентификатор(); //СледующаяСтрока;//Объект.ТЗМатериалы.Индекс(СледующаяСтрока);
КонецПроцедуры


 

Tags:
Subscribe

Posts from This Journal “1С” Tag

  • Долгострои 1С

    Если вы хотите узнать, почему программисты 1С любят платформу 1С и местами ненавидят разработчиков этой платформы, то сейчас я Вам расскажу. Уже 10…

  • Ловкость рук и обработка результата запроса

    Как то я пообещал заказчику, что обработаю определенный список документов, но забыл, что эти документы были в базе с управляемыми формами. Как быть?…

  • 1С и искусственные серверные барьеры

    Заметил, что в управляемых формах 1С принуждает программистов к плохой архитектуре решений. Вкратце упомяну, что теперь большинство внешних…

  • Особенности белорусского Налогоплательщика

    Взял подработку у одного знакомого чувака из Беларуси. Платил мало (я то беру 1500 в час, а там по 800), но знакомый хороший, грех было отказывать,…

  • 1С отрицает очевидное

    Работаю с флагманом 1С, конфигурацией ERP. Вижу, что 1С прошило всю конфигурацию обращениями к модулям, где разработчик, внедряющий 1С может…

  • Как обмануть макет 1с?

    В 1С можно менять макеты в режиме 1с Предприятия. Но 1с-овцы не подумали, что пользователи не захотят видеть некоторые поля. Если просто удалить…

  • Корректировка регистра на 80 документов

    Мне прислали список из 80 документов, суммы которых нужно было внести в УПП в документ корректировки записей регистров для того, чтобы закрыть…

  • Ручной способ получить список реквизитов справочников

    Была поставлена задача расписать реквизиты справочника договоров и контрагентов в двух базах, написать соответствия между ними. Для начала нужно…

  • Открытие файла с нужным именем

    Небольшой гуру-тест. При сохранении файла в базу 1С сохраняется его первоначальное имя, например «Договор ННН.PDF». Задача – при открытии файла из…

promo fixin декабрь 28, 2020 16:57 1387
Buy for 30 tokens
Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект " Секс за Ваши". Если вы хотите написать пост обо мне или почитать, что пишут…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 43 comments