fixin (fixin) wrote,
fixin
fixin

Перемещение по строкам документа

Перемещение на предыдущую-следующую строку в 1С УФ.

Казалось бы, реализация таких простых кнопок, как переход к предыщей/следующей строке в списке табличной части обработки потребовало в управляемых формах много времени, чтобы разобраться.
 

Решение заключалось в вызове метода ПолучитьИдентификатор.

В итоге получился код:


&НаКлиенте
Процедура СледующаяСтрокаМатериалов(Команда)
 
ПереместитьСтрокуМатериалов(1);
КонецПроцедуры

&НаКлиенте
Процедура ПредыдущаяСтрокаМатериалов(Команда)
 
ПереместитьСтрокуМатериалов(-1);
КонецПроцедуры

&НаКлиенте
Процедура ПереместитьСтрокуМатериалов(Направление)
 Если
Элементы.ТЗМатериалы.ТекущиеДанные = Неопределено  Тогда
  Возврат;
 КонецЕсли;

 
ТекНомерСтроки = Элементы.ТЗМатериалы.ТекущиеДанные.НомерСтроки;
 Если
ТекНомерСтроки = Объект.ТЗМатериалы.Количество() И Направление = 1 Тогда
  Возврат;
 КонецЕсли;
 Если
ТекНомерСтроки = 1 И Направление = -1 Тогда
  Возврат;
 КонецЕсли;

 
СледующаяСтрока = Объект.ТЗМатериалы[ТекНомерСтроки - 1 + Направление];

 
Элементы.ТЗМатериалы.ТекущаяСтрока = СледующаяСтрока.ПолучитьИдентификатор(); //СледующаяСтрока;//Объект.ТЗМатериалы.Индекс(СледующаяСтрока);
КонецПроцедуры


 

Tags:
Subscribe

Posts from This Journal “1С” Tag

  • Коварный ввод на основании в УФ

    На основании документа Х можно вводить два документа А и Б. Но конкретный вид документа зависит от содержимого документа Х (вида операции). Решили…

  • Правило назначения ролей – не запрещать!

    Есть одно правило назначения ролей пользователей, которое выработано эмпирически и скорее обосновано чутьём. Нельзя делать запреты пользователям с…

  • Гуру-тест 1С: обмануть при записи

    Итак, задачка. Нужно, чтобы при записи новая версия объекта не поместилась в базу данных, но при этом не была сгенерирована ошибка или отказ. Случай…

  • Долгострои 1С

    Если вы хотите узнать, почему программисты 1С любят платформу 1С и местами ненавидят разработчиков этой платформы, то сейчас я Вам расскажу. Уже 10…

  • Ловкость рук и обработка результата запроса

    Как то я пообещал заказчику, что обработаю определенный список документов, но забыл, что эти документы были в базе с управляемыми формами. Как быть?…

  • 1С и искусственные серверные барьеры

    Заметил, что в управляемых формах 1С принуждает программистов к плохой архитектуре решений. Вкратце упомяну, что теперь большинство внешних…

  • Особенности белорусского Налогоплательщика

    Взял подработку у одного знакомого чувака из Беларуси. Платил мало (я то беру 1500 в час, а там по 800), но знакомый хороший, грех было отказывать,…

  • 1С отрицает очевидное

    Работаю с флагманом 1С, конфигурацией ERP. Вижу, что 1С прошило всю конфигурацию обращениями к модулям, где разработчик, внедряющий 1С может…

  • Как обмануть макет 1с?

    В 1С можно менять макеты в режиме 1с Предприятия. Но 1с-овцы не подумали, что пользователи не захотят видеть некоторые поля. Если просто удалить…

Buy for 40 tokens
Отставить педрилование! Дело-то серьёзное. Абы в чем, в рваном спорткостюме, пусть ходят на свиданки неандерталы с челябинских окраин. А приличному человеку - стыдно, поэтому у меня с собою было привезено новое/фирменное. Да, это было уже пятое свидание с моим любимчиком. Чёрт-те знает где, на…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 43 comments