fixin (fixin) wrote,
fixin
fixin

Перемещение по строкам документа

Перемещение на предыдущую-следующую строку в 1С УФ.

Казалось бы, реализация таких простых кнопок, как переход к предыщей/следующей строке в списке табличной части обработки потребовало в управляемых формах много времени, чтобы разобраться.
 

Решение заключалось в вызове метода ПолучитьИдентификатор.

В итоге получился код:


&НаКлиенте
Процедура СледующаяСтрокаМатериалов(Команда)
 
ПереместитьСтрокуМатериалов(1);
КонецПроцедуры

&НаКлиенте
Процедура ПредыдущаяСтрокаМатериалов(Команда)
 
ПереместитьСтрокуМатериалов(-1);
КонецПроцедуры

&НаКлиенте
Процедура ПереместитьСтрокуМатериалов(Направление)
 Если
Элементы.ТЗМатериалы.ТекущиеДанные = Неопределено  Тогда
  Возврат;
 КонецЕсли;

 
ТекНомерСтроки = Элементы.ТЗМатериалы.ТекущиеДанные.НомерСтроки;
 Если
ТекНомерСтроки = Объект.ТЗМатериалы.Количество() И Направление = 1 Тогда
  Возврат;
 КонецЕсли;
 Если
ТекНомерСтроки = 1 И Направление = -1 Тогда
  Возврат;
 КонецЕсли;

 
СледующаяСтрока = Объект.ТЗМатериалы[ТекНомерСтроки - 1 + Направление];

 
Элементы.ТЗМатериалы.ТекущаяСтрока = СледующаяСтрока.ПолучитьИдентификатор(); //СледующаяСтрока;//Объект.ТЗМатериалы.Индекс(СледующаяСтрока);
КонецПроцедуры


 

Tags:
Subscribe
promo fixin december 31, 2037 16:57 1417
Buy for 30 tokens
UPD: Друзья, в августе 2019 года блог переехал на http://fixinchik.ru. Welcome! Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект "…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 34 comments