fixin (fixin) wrote,
fixin
fixin

Загрузка номенклатуры из 77 в БП3 (перегонка)

Мой опыт использования типовой загрузки данных из табличного документа для загрузки номенклатуры в БП 3.0 УФ

Посмотрел все обработки для загрузки номенклатуры. Ни одна не подошла, поэтому пришлось использовать старую добрую загрузку из табличного документа. Рассказываю, как это сделал.

Анализ готовых решений

Готовые обработки переноса были слишком простыми и не совсем заточены под Бухгалтерию и Розницу, большинство было под УТ11. К тому же, мне нужно было перенести папку, полное наименование и страну.

Вот эта https://infostart.ru/public/256317 не могла грузить полное наименование и страну.

Смотрел еще https://infostart.ru/public/96398, https://infostart.ru/public/424406.

Были еще платные решения, но на них у меня не было денег.

Поэтому пошел своим путем.

Выгрузка из 7.7

Выгрузку номенклатуры делал через Refprint, слегка допиленный, скачал с Инфостарта.

Получил номенклатуру в плоском табличном виде с наименованиями групп:

Данные в Excel перенес через буфер обмена, на больших обменах сохранение в Excel умирает. Теперь нужно было загрузить это добро в БП3.

Запуск 1С в режиме обычного приложения

Для работы с типовой обработкой по загрузке из табличного документа нужно было запустить 1С в режиме обычного приложения, для этого я прописал параметр запуска 1С RunModeOrdinaryApplication.

 

Загрузка данных в БП 3.0

В запущенной в режиме обычного приложения 1С открыл обработку и через буфер обмена скопировал таблицу из Excel в 1С:

Выбрал загрузку в справочник «Номенклатура».

На странице настроек указал ручной порядок нумерации колонок и сделал настройку соответствий:

Код по кнопке «События» указал такой (нумерация колонок в коде соответствует нумерации колонок в таблице):


Сообщить("Объект: " + Объект);
ИскЗн = ТекстыЯчеек[11];
Если
ИскЗн <> "" Тогда
 
Иск = Справочники.КлассификаторЕдиницИзмерения.НайтиПоНаименованию(ИскЗн, истина);
 Если Не
ЗначениеЗаполнено(Иск) Тогда
 
ИскО = Справочники.КлассификаторЕдиницИзмерения.СоздатьЭлемент();
 
ИскО.Наименование = ИскЗн;
 
ИскО.ОбменДанными.Загрузка = истина;
 
ИскО.Записать();
 
Иск = ИскО.Ссылка;
 КонецЕсли;
 
Объект.ЕдиницаИзмерения = Иск;
КонецЕсли;
Сообщить("  Единица: " + Объект.ЕдиницаИзмерения + ":" + ИскЗн);
ИскЗн = ТекстыЯчеек[5];
Если
ИскЗн <> "" Тогда
 
Иск = Справочники.Номенклатура.НайтиПоНаименованию(ИскЗн, истина);
 Если Не
ЗначениеЗаполнено(Иск) Тогда
 
ИскО = Справочники.Номенклатура.СоздатьГруппу();
 
ИскО.Наименование = ИскЗн;
 
ИскО.Записать();
 
Иск = ИскО.Ссылка;
 КонецЕсли;
 
Объект.Родитель = Иск;
КонецЕсли;
Сообщить("  Родитель: " + Объект.Родитель + ":" + ИскЗн);
ИскЗн = ТекстыЯчеек[25];
Если
ИскЗн <> "" Тогда
 
Иск = Справочники.Номенклатура.НайтиПоНаименованию(ИскЗн, истина);
 Если Не
ЗначениеЗаполнено(Иск) Тогда
 
ИскО = Справочники.СтраныМира.СоздатьЭлемент();
 
ИскО.Наименование = ИскЗн;
 
ИскО.ОбменДанными.Загрузка = истина;
 
ИскО.Записать();
 
Иск = ИскО.Ссылка;
 КонецЕсли;
 
Объект.СтранаПроисхождения = Иск;
КонецЕсли;
Сообщить("  Страна происхождения: " + Объект.СтранаПроисхождения + ":" + ИскЗн);

После этого запустил загрузку и всё загрузилось по папочкам, с единицами по количеству в упаковке и со странами мира. Примерно 3 000 позиций в данном конкретном случае.


 

Tags:
Subscribe

Posts from This Journal “1С” Tag

  • 1С и искусственные серверные барьеры

    Заметил, что в управляемых формах 1С принуждает программистов к плохой архитектуре решений. Вкратце упомяну, что теперь большинство внешних…

  • Особенности белорусского Налогоплательщика

    Взял подработку у одного знакомого чувака из Беларуси. Платил мало (я то беру 1500 в час, а там по 800), но знакомый хороший, грех было отказывать,…

  • 1С отрицает очевидное

    Работаю с флагманом 1С, конфигурацией ERP. Вижу, что 1С прошило всю конфигурацию обращениями к модулям, где разработчик, внедряющий 1С может…

  • Как обмануть макет 1с?

    В 1С можно менять макеты в режиме 1с Предприятия. Но 1с-овцы не подумали, что пользователи не захотят видеть некоторые поля. Если просто удалить…

  • Корректировка регистра на 80 документов

    Мне прислали список из 80 документов, суммы которых нужно было внести в УПП в документ корректировки записей регистров для того, чтобы закрыть…

  • Ручной способ получить список реквизитов справочников

    Была поставлена задача расписать реквизиты справочника договоров и контрагентов в двух базах, написать соответствия между ними. Для начала нужно…

  • Открытие файла с нужным именем

    Небольшой гуру-тест. При сохранении файла в базу 1С сохраняется его первоначальное имя, например «Договор ННН.PDF». Задача – при открытии файла из…

  • Перемещение по строкам документа

    Перемещение на предыдущую-следующую строку в 1С УФ. Казалось бы, реализация таких простых кнопок, как переход к предыщей/следующей строке в списке…

  • Гипер-рефакторинг силами Гения 1С

    У клиента, к которому я пришел делать доработки по бизнес-процессам на УПП, вскрылось, что архитектура изуродована множественными копипастами, на…

promo kibernetika 20:58, вчера 5
Buy for 40 tokens
Одно время мой закадычный друг в Йемене, Саша Воронин, жил в Сане в типичном йеменском доме, который хозяин через министерство обороны сдавал…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 68 comments