fixin (fixin) wrote,
fixin
fixin

Допил универсального редактора реквизитов

Давно использую Универсальный редактор реквизитов версии 2.1 от Организации Неизбежности Светлого Будущего http://onsb.org. Он работает для обычных и управляемых форм. Но, к сожалению,  он не умеет менять реквизиты адресации задач. Пришлось его допилить, чтобы мог. Правки делал для управляемой формы, потому что использовал для конфигурации «1С: Документооборот».

Когда заполняется список реквизитов, добавил:


 ДобавитьРеквизитыНаФорму(МассивРеквизитов, "ОбщиеРеквизиты");
 
ДобавитьРеквизитыНаФорму(мдОбъекта.СтандартныеРеквизиты, "СтандартныеРеквизиты");

 
//Осипов - для реквизитов адресации
 
Если Метаданные.Задачи.Индекс(мдОбъекта) >= 0 Тогда
 
ДобавитьРеквизитыНаФорму(мдОбъекта.РеквизитыАдресации, "СтандартныеРеквизиты");
 КонецЕсли;

И когда данные переносятся из формы в объект, добавил:


 //Осипов - для реквизитов адресации
 
Если Метаданные.Задачи.Индекс(мдОбъекта) >= 0 Тогда

  Для Каждого
мдРеквизита из мдОбъекта.РеквизитыАдресации Цикл
   Если НЕ (
мдРеквизита.Имя = "Ссылка" или мдРеквизита.Имя = "Ref" ИЛИ мдРеквизита.Имя = "Предопределенный" или мдРеквизита.Имя = "Predefined"
   
ИЛИ мдРеквизита.Имя = "Проведен" ИЛИ мдРеквизита.Имя = "Posted" ИЛИ мдРеквизита.Имя = "ЭтоГруппа"  ИЛИ мдРеквизита.Имя = "IsFolder") Тогда
   
ВыбОбъект[мдРеквизита.Имя] = ЭтаФорма["lyay" + мдРеквизита.Имя];
   КонецЕсли;
  КонецЦикла;

 КонецЕсли;

Обратите внимание, что РеквизитыАдресации есть только у задач, поэтому делается проверка на их существование.

Tags:
Subscribe

Posts from This Journal “1С” Tag

  • Торговля, Бухгалтерия и Зарплата в 1С

    Бытие влияет на сознание, как говаривал Ленин! Когда изучал Navision, то при всей её архаичности, эта система имела общую конфигурацию, из которой…

  • Незамутненный 1сник.

    На инфостарте столкнулся с забавным "критиком", которому не понравилась одна моя статья. Почитайте нашу перепиську, это забавно:…

  • Visual Basic + 1С всё?

    Вот и верь после этого Одину Эссу!? Как-то, еще на работе в Максимусе, мне понадобилось написать внешнюю компоненту для управления сканером…

  • Вы всё еще кастрируете?

    Для отладки бизнес-процессов согласования договоров прежде, чем дело дойдет до утверждения, нужно пройти длинную цепочку согласований. Чтобы не…

  • Коварный ввод на основании в УФ

    На основании документа Х можно вводить два документа А и Б. Но конкретный вид документа зависит от содержимого документа Х (вида операции). Решили…

  • Правило назначения ролей – не запрещать!

    Есть одно правило назначения ролей пользователей, которое выработано эмпирически и скорее обосновано чутьём. Нельзя делать запреты пользователям с…

  • Гуру-тест 1С: обмануть при записи

    Итак, задачка. Нужно, чтобы при записи новая версия объекта не поместилась в базу данных, но при этом не была сгенерирована ошибка или отказ. Случай…

  • Долгострои 1С

    Если вы хотите узнать, почему программисты 1С любят платформу 1С и местами ненавидят разработчиков этой платформы, то сейчас я Вам расскажу. Уже 10…

  • Ловкость рук и обработка результата запроса

    Как то я пообещал заказчику, что обработаю определенный список документов, но забыл, что эти документы были в базе с управляемыми формами. Как быть?…

promo fixin december 28, 2020 16:57 1406
Buy for 30 tokens
Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект " Секс за Ваши". Если вы хотите написать пост обо мне или почитать, что пишут…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 20 comments