fixin (fixin) wrote,
fixin
fixin

Допил универсального редактора реквизитов

Давно использую Универсальный редактор реквизитов версии 2.1 от Организации Неизбежности Светлого Будущего http://onsb.org. Он работает для обычных и управляемых форм. Но, к сожалению,  он не умеет менять реквизиты адресации задач. Пришлось его допилить, чтобы мог. Правки делал для управляемой формы, потому что использовал для конфигурации «1С: Документооборот».

Когда заполняется список реквизитов, добавил:


 ДобавитьРеквизитыНаФорму(МассивРеквизитов, "ОбщиеРеквизиты");
 
ДобавитьРеквизитыНаФорму(мдОбъекта.СтандартныеРеквизиты, "СтандартныеРеквизиты");

 
//Осипов - для реквизитов адресации
 
Если Метаданные.Задачи.Индекс(мдОбъекта) >= 0 Тогда
 
ДобавитьРеквизитыНаФорму(мдОбъекта.РеквизитыАдресации, "СтандартныеРеквизиты");
 КонецЕсли;

И когда данные переносятся из формы в объект, добавил:


 //Осипов - для реквизитов адресации
 
Если Метаданные.Задачи.Индекс(мдОбъекта) >= 0 Тогда

  Для Каждого
мдРеквизита из мдОбъекта.РеквизитыАдресации Цикл
   Если НЕ (
мдРеквизита.Имя = "Ссылка" или мдРеквизита.Имя = "Ref" ИЛИ мдРеквизита.Имя = "Предопределенный" или мдРеквизита.Имя = "Predefined"
   
ИЛИ мдРеквизита.Имя = "Проведен" ИЛИ мдРеквизита.Имя = "Posted" ИЛИ мдРеквизита.Имя = "ЭтоГруппа"  ИЛИ мдРеквизита.Имя = "IsFolder") Тогда
   
ВыбОбъект[мдРеквизита.Имя] = ЭтаФорма["lyay" + мдРеквизита.Имя];
   КонецЕсли;
  КонецЦикла;

 КонецЕсли;

Обратите внимание, что РеквизитыАдресации есть только у задач, поэтому делается проверка на их существование.

Tags:
Subscribe
promo fixin december 31, 2037 16:57 1417
Buy for 30 tokens
UPD: Друзья, в августе 2019 года блог переехал на http://fixinchik.ru. Welcome! Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект "…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 16 comments