fixin (fixin) wrote,
fixin
fixin

Рубим лесенки из Если

Допустим есть код вида:

Если А Тогда КодА
Если Б Тогда КодБ
Если В Тогда КодВ
Иначе КодНеВ
КонецЕсли
Иначе КодНеБ
КонецЕсли
Иначе КодНеА
КонецЕсли

Это называется "условный оператор из ада".

Как заменить его на адекватный, читаемый код? Ответ под катом.

Пока Истина Цикл
Если А Тогда КодА;
Иначе КодНеА; Прервать; Конец
Если Б Тогда КодБ;
Иначе КодНеБ; Прервать; Конец
Если В Тогда КодВ;
Иначе КодНеВ; Прервать; Конец
Прервать;
КонецЦикла

Если вынести условный оператор в процедуру, то вместо Прервать можно использовать Возврат.
Tags: , ручки
Subscribe

Posts from This Journal “1с” Tag

  • Удаленка в 1С

    Посмотрел вакансии программиста 1С на HH с возможностью работы из дома. Что мы там имеем?…

  • Почему 1Сники работают за 1000, а не за 2500?

    Ихтя, который имеет отношение к бизнесу 1С задал мне вопрос: «Почему клиенты работают с франчайзи за 2500 в час, а программисту достается только…

  • Бизнес-процессы в 1С – закономерный печальный итог

    В конфигурации «Управление холдингом» типовой механизм платформы «Бизнес-процессы» не используется. Вместо него используются справочники и регистры.…

  • Вы берете с родственников деньги?

    Я вот недавно с одних из своих родственников решил брать деньги за настройку 1С. Со скидкой, но все же. Потому что после того, как перейду на…

  • Я - опытный проктолог

    Как часто у меня в работе бывает такое, что начинаешь решать какую-то сложную проблему, особенно в навороченных типовых конфигурациях и кажется, что…

  • Торговля, Бухгалтерия и Зарплата в 1С

    Бытие влияет на сознание, как говаривал Ленин! Когда изучал Navision, то при всей её архаичности, эта система имела общую конфигурацию, из которой…

  • Незамутненный 1сник.

    На инфостарте столкнулся с забавным "критиком", которому не понравилась одна моя статья. Почитайте нашу перепиську, это забавно:…

  • Visual Basic + 1С всё?

    Вот и верь после этого Одину Эссу!? Как-то, еще на работе в Максимусе, мне понадобилось написать внешнюю компоненту для управления сканером…

  • Вы всё еще кастрируете?

    Для отладки бизнес-процессов согласования договоров прежде, чем дело дойдет до утверждения, нужно пройти длинную цепочку согласований. Чтобы не…

promo fixin december 31, 2037 16:57 1415
Buy for 30 tokens
UPD: Друзья, в августе 2019 года блог переехал на http://fixinchik.ru. Welcome! Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект "…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 159 comments
Previous
← Ctrl ← Alt
Next
Ctrl → Alt →
Previous
← Ctrl ← Alt
Next
Ctrl → Alt →