fixin (fixin) wrote,
fixin
fixin

Category:

Схема запроса

В новых релизах 1С8 появился объект схема запроса. С ним сопровождать типовые конфигурации стало еще удобнее.

Если нужно хирургически вмешаться в запрос, теперь не требуется вручную разбирать текст запроса, можно загрузить его в схему, программно добавить нужные изменения и собрать обратно в текст из схемы.

Удобно, даже я использовал на практике для добавления отбора по ответственному в одном из типовых отчетов:


Процедура ДобавитьФильтрПоОтветственному(Запрос, ВыражениеПоля);
 
//РИТ Осипов 2017-02-16
 //Чтобы работал отбор по ответственному
 
Если ЗначениеЗаполнено(ВыбОтветственный) Тогда
 
СЗ = Новый СхемаЗапроса();
 
СЗ.УстановитьТекстЗапроса(Запрос.Текст);
  Для Каждого
ТекСхема ИЗ СЗ.ПакетЗапросов Цикл
   Для Каждого
ТекОператор ИЗ ТекСхема.Операторы Цикл
   
ТекОтбор = ТекОператор.Отбор;
   
ТекОтбор.Добавить(ВыражениеПоля + ".Ответственный = &Ответственный");
   КонецЦикла;
  
//ТекОтбор.Добавить();
 
КонецЦикла;
 
Запрос.Текст = СЗ.ПолучитьТекстЗапроса();
 
Запрос.УстановитьПараметр("Ответственный", ВыбОтветственный);
 КонецЕсли;
КонецПроцедуры


Tags:
Subscribe
promo fixin december 31, 2037 16:57 1417
Buy for 30 tokens
UPD: Друзья, в августе 2019 года блог переехал на http://fixinchik.ru. Welcome! Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект "…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 15 comments