October 23rd, 2017

свин

Выбор страховой по ипотеке

Помните, я писал про выбор страховой компании для ипотеки, который мне нужно было сделать.  Абсолют перестал работать с СК РГС-Столица и мне пришлось заключать договор с новой СК.

Я честно прозвонил все компании, но оказалось, что цены везде практические одинаковые.

Менеджер ВСК, дай бог ему здоровья, посоветовал отказаться от страхования титула, если прошло более 3х лет с покупки. Страховка будет дешевле.

Я позвонил в банк и действительно, можно подать заявление на отказ от титула, его рассмотрят и подтвердят. Пришел в банк писать заявление, чтобы застраховаться в ВСК (из чувства благодарности менеджеру), но мне сказали, что если я буду страховаться в СК Благосостояние, то мне не нужно писать заявление.

Collapse )

promo fixin december 31, 2037 16:57 1420
Buy for 30 tokens
UPD: Друзья, в августе 2019 года блог переехал на http://fixinchik.ru. Welcome! Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект "…
свин

Проекты для 2-го класса

Что-то во втором классе стали много на «Окружающем мире» задавать проектов, где нужно вклеивать фотки. Например «Город и дом, где я живу».

Пришлось пофоткать свой дом, нагуглить Ленина и Лисью гору.

Прикол в том, что фотки нужно распечатать на принтере. Разумеется, это делают родители, т.к. ребенок не напечатает.

У меня как-то было под вопросом, заночую ли я дома, и Анка устроила истерику, что если бы я не пришел, то сорвался бы проект у малого.

Я спросил – а как быть тем, у кого нет принтеров? Говорит – у всех есть.

Collapse )

свин

Хитрый двухуровневый кэш

Как вам такой хитрый двухуровневый кэш?

Первый уровень – ДатаПотребности, второй – Номенклатура, на третьем – массив Заказов.

Искать можно без учета заказов, тогда будут возвращены все заказы и по конкретному заказу, тогда заказ ищется перебором в массиве на втором уровне кэша. Массивы маленькие, перебор работает быстро.

Перебираем все строки и заносим их в кэш: 


//Кэш строк документа
 
КэшСтрокДокумента = Новый Соответствие();
 Для Каждого
Строка ИЗ Объект.ОбеспечениеПотребности Цикл
 
ДобавитьВКэшСтрокДокумента(КэшСтрокДокумента, Строка);
 КонецЦикла;
Сама процедура занесения в кэш:
Процедура
ДобавитьВКэшСтрокДокумента(Кэш, Строка) Экспорт
 
Кэш2 = Кэш[Строка.ДатаПотребности];
 Если
Кэш2 = Неопределено Тогда
 
Кэш2 = Новый Соответствие();
 
Кэш.Вставить(Строка.ДатаПотребности, Кэш2);
 КонецЕсли;
 
Кэш3 = Кэш2[Строка.Номенклатура];
 Если
Кэш3 = Неопределено Тогда
 
Кэш3 = Новый Массив();
 
Кэш2.Вставить(Строка.Номенклатура, Кэш3);
 КонецЕсли;
 
Кэш3.Добавить(Строка);
КонецПроцедуры
Функция
поиска в кэше:
Функция
НайтиВКэшеСтрокиДокумента(Кэш, ДатаПотребности, Номенклатура, Заказ = Неопределено, Подразделение = Неопределено) Экспорт
 
М = Новый Массив();

 
Кэш2 = Кэш[ДатаПотребности];
 Если
Кэш2 = Неопределено Тогда
  Возврат
М;
 КонецЕсли;

 
Кэш3 = Кэш2[Номенклатура];
 Если
Кэш3 = Неопределено Тогда
  Возврат
М;
 КонецЕсли;

 Если
Заказ = Неопределено Тогда
  Возврат
Кэш3;
 КонецЕсли;

 Для Каждого
Эл ИЗ Кэш3 Цикл
  Если
Эл.Заказ = Заказ
   И (Подразделение = Неопределено ИЛИ Эл.Подразделение = Подразделение)
   Тогда
  
М.Добавить(Эл);
  КонецЕсли;
 КонецЦикла;

 Возврат
М;

КонецФункции

Каково, а?! Летает!