October 4th, 2017

promo fixin december 31, 2037 16:57 1417
Buy for 30 tokens
UPD: Друзья, в августе 2019 года блог переехал на http://fixinchik.ru. Welcome! Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект "…
свин

Раскоряка остепенилась

Нельзя рассчитывать 5 лет трахать и выставлять напотеху жж френдам в раскоряченных позах молодую телочку 30 лет, если ты ее в 1.5 раза старше и не можешь предложить ничего кроме "ветра странствий".

Даже если она косоглазая и татуированная, она найдет себе варианты получше.



Collapse )
свин

Загрузка номенклатуры из 77 в БП3 (перегонка)

Мой опыт использования типовой загрузки данных из табличного документа для загрузки номенклатуры в БП 3.0 УФ

Посмотрел все обработки для загрузки номенклатуры. Ни одна не подошла, поэтому пришлось использовать старую добрую загрузку из табличного документа. Рассказываю, как это сделал.

Анализ готовых решений

Готовые обработки переноса были слишком простыми и не совсем заточены под Бухгалтерию и Розницу, большинство было под УТ11. К тому же, мне нужно было перенести папку, полное наименование и страну.

Вот эта https://infostart.ru/public/256317 не могла грузить полное наименование и страну.

Смотрел еще https://infostart.ru/public/96398, https://infostart.ru/public/424406.

Были еще платные решения, но на них у меня не было денег.

Поэтому пошел своим путем.

Выгрузка из 7.7

Выгрузку номенклатуры делал через Refprint, слегка допиленный, скачал с Инфостарта.

Получил номенклатуру в плоском табличном виде с наименованиями групп:

Данные в Excel перенес через буфер обмена, на больших обменах сохранение в Excel умирает. Теперь нужно было загрузить это добро в БП3.

Запуск 1С в режиме обычного приложения

Для работы с типовой обработкой по загрузке из табличного документа нужно было запустить 1С в режиме обычного приложения, для этого я прописал параметр запуска 1С RunModeOrdinaryApplication.

 

Загрузка данных в БП 3.0

В запущенной в режиме обычного приложения 1С открыл обработку и через буфер обмена скопировал таблицу из Excel в 1С:

Выбрал загрузку в справочник «Номенклатура».

На странице настроек указал ручной порядок нумерации колонок и сделал настройку соответствий:

Код по кнопке «События» указал такой (нумерация колонок в коде соответствует нумерации колонок в таблице):


Сообщить("Объект: " + Объект);
ИскЗн = ТекстыЯчеек[11];
Если
ИскЗн <> "" Тогда
 
Иск = Справочники.КлассификаторЕдиницИзмерения.НайтиПоНаименованию(ИскЗн, истина);
 Если Не
ЗначениеЗаполнено(Иск) Тогда
 
ИскО = Справочники.КлассификаторЕдиницИзмерения.СоздатьЭлемент();
 
ИскО.Наименование = ИскЗн;
 
ИскО.ОбменДанными.Загрузка = истина;
 
ИскО.Записать();
 
Иск = ИскО.Ссылка;
 КонецЕсли;
 
Объект.ЕдиницаИзмерения = Иск;
КонецЕсли;
Сообщить("  Единица: " + Объект.ЕдиницаИзмерения + ":" + ИскЗн);
ИскЗн = ТекстыЯчеек[5];
Если
ИскЗн <> "" Тогда
 
Иск = Справочники.Номенклатура.НайтиПоНаименованию(ИскЗн, истина);
 Если Не
ЗначениеЗаполнено(Иск) Тогда
 
ИскО = Справочники.Номенклатура.СоздатьГруппу();
 
ИскО.Наименование = ИскЗн;
 
ИскО.Записать();
 
Иск = ИскО.Ссылка;
 КонецЕсли;
 
Объект.Родитель = Иск;
КонецЕсли;
Сообщить("  Родитель: " + Объект.Родитель + ":" + ИскЗн);
ИскЗн = ТекстыЯчеек[25];
Если
ИскЗн <> "" Тогда
 
Иск = Справочники.Номенклатура.НайтиПоНаименованию(ИскЗн, истина);
 Если Не
ЗначениеЗаполнено(Иск) Тогда
 
ИскО = Справочники.СтраныМира.СоздатьЭлемент();
 
ИскО.Наименование = ИскЗн;
 
ИскО.ОбменДанными.Загрузка = истина;
 
ИскО.Записать();
 
Иск = ИскО.Ссылка;
 КонецЕсли;
 
Объект.СтранаПроисхождения = Иск;
КонецЕсли;
Сообщить("  Страна происхождения: " + Объект.СтранаПроисхождения + ":" + ИскЗн);

После этого запустил загрузку и всё загрузилось по папочкам, с единицами по количеству в упаковке и со странами мира. Примерно 3 000 позиций в данном конкретном случае.