August 17th, 2017

свин

В топку MLO

С июля 2015 года я перестал вести тщательный учет денег, т.к. понял, что полный учет не успеваю вести, он отнимает у меня время.

Верный Дескампада предположил, что и MLO скоро последует та же участь. Но нет, пока держится.

Я научился решать с её помощью некоторый класс задач, но все же охват тоже не 100%, к сожалению.

И проблема тут не в MLO, а в том, что нету времени выстроить систему, охватывающую все виды задач.

promo fixin декабрь 31, 2037 16:57 1420
Buy for 30 tokens
UPD: Друзья, в августе 2019 года блог переехал на http://fixinchik.ru. Welcome! Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект "…
свин

Рубим лесенки из Если

Допустим есть код вида:

Если А Тогда КодА
Если Б Тогда КодБ
Если В Тогда КодВ
Иначе КодНеВ
КонецЕсли
Иначе КодНеБ
КонецЕсли
Иначе КодНеА
КонецЕсли

Это называется "условный оператор из ада".

Как заменить его на адекватный, читаемый код? Ответ под катом.

Collapse )
свин

Анке - МТС за спасибо

Вот уже с Нового Года, пожалуй, оплачиваю Анке МТС через СПАСИБО от Сбербанка.

Там на квартал набегает 1000 баллов, ей как раз хватает. Набегает в основном за счет беспроцентной грейс-кредитки в 15 000 рублей, которую Анка опустошает целиком за месяц.

Вот и нынче сделал очередной платеж, месяца на два с половиной хватит.

Наличными надо оплачивать 1% от платежа спасибками.