March 14th, 2017

свин

Или бабы дуры или умные слишком.

Новая неделя встретила меня любовным разочарованием.

Еще в четверг после тренировки я зажимался в машине с изумительной женщиной, в которую готов был влюбиться. Мы пропустили несколько электричек и только потом оторвались друг от друга. В романтическом бреду я мечтал, как заведу с ней вторую семью и будем жить душа в душу.

Ну а дальше она прогуглила мою фамилию, которую я ей сболтнул. И решила, что не хочет иметь со мной отношений, о чём сообщила в понедельник.

Collapse )

promo fixin декабрь 31, 2037 16:57 1420
Buy for 30 tokens
UPD: Друзья, в августе 2019 года блог переехал на http://fixinchik.ru. Welcome! Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект "…
свин

Малой и «Ваши таланты»

Руслан вслух читает в KFC объявление – «Нам требуются Ваши таланты» и спрашивает – папа, они ищут на работу? Вывод, правильный, но прямо скажем, неожиданный, не думал, что ребёнок может сообразить и связать таланты и работу.

Пока я пребываю в легком офигевании и умилении от его соображалки, Руслан продолжает – папа, а может ты сюда устроишься?

Я говорю – нет, здесь мне будут мало платить.

Руслан не сдается и говорит – ну если народу будет много, то ты здесь будешь много денег получать.

Тогда я объяснил: Увы, нет. Как программисту мне заплатят намного больше, чем как продавцу.


свин

Схема запроса

В новых релизах 1С8 появился объект схема запроса. С ним сопровождать типовые конфигурации стало еще удобнее.

Если нужно хирургически вмешаться в запрос, теперь не требуется вручную разбирать текст запроса, можно загрузить его в схему, программно добавить нужные изменения и собрать обратно в текст из схемы.

Удобно, даже я использовал на практике для добавления отбора по ответственному в одном из типовых отчетов:


Процедура ДобавитьФильтрПоОтветственному(Запрос, ВыражениеПоля);
 
//РИТ Осипов 2017-02-16
 //Чтобы работал отбор по ответственному
 
Если ЗначениеЗаполнено(ВыбОтветственный) Тогда
 
СЗ = Новый СхемаЗапроса();
 
СЗ.УстановитьТекстЗапроса(Запрос.Текст);
  Для Каждого
ТекСхема ИЗ СЗ.ПакетЗапросов Цикл
   Для Каждого
ТекОператор ИЗ ТекСхема.Операторы Цикл
   
ТекОтбор = ТекОператор.Отбор;
   
ТекОтбор.Добавить(ВыражениеПоля + ".Ответственный = &Ответственный");
   КонецЦикла;
  
//ТекОтбор.Добавить();
 
КонецЦикла;
 
Запрос.Текст = СЗ.ПолучитьТекстЗапроса();
 
Запрос.УстановитьПараметр("Ответственный", ВыбОтветственный);
 КонецЕсли;
КонецПроцедуры


свин

Не подписались на «Дамский час»

Как-то Анка сказала, что в субботу повезёт малого в медицинский центр, чтобы я был готов заказать такси.

Я прикинул, что поездочка продлится час, и пригласил двух самочек-соседушек из Железки, которые в курсе моего семейного положения,  на быстрый перепихончик.

Они не смогли, но увы, Анка заставила меня ехать с ней – за компанию. Бдит.


свин

Трехсвиданка

Сегодня был на трех стрелках на 18, 19 и 20 часов. Наш пострел везде поспел. Последней предложил счет пополам, она согласилась.

Думаю, надо переносить статистический метод на стрелки.

То бишь назначать стрелки с интервалом в 30 минут. Идти в кафе. Предлагать платить пополам. Не хочет - прогуляться, можно и до метро.

В кафе через 5-10 минут беседы предлагать целоваться. Если в отказ, то закругляться и идти на следующую стрелку.

Если соглашается, то предлагать в следующий раз в отель. В любом случае разбегаться и идти на следующую стрелку.

Всё равно что-то не выгорает, за исключением Елфе, Кучернат и Микрома.