fixin (fixin) wrote,
fixin
fixin

Category:

Красоты кода для СКД



Написал красивый код по копированию отбора в СКД:


Пример вызова:


СкопироватьОтборСКД(Компоновщик.Настройки.Отбор, КомпоновщикНастроек.Настройки.Отбор);


Код функции:


Функция СкопироватьОтборСКД(Приемник, Источник, Очищать = истина) Экспорт
 Если Очищать Тогда
  Приемник.Элементы.Очистить(); 
 КонецЕсли;
 Для Каждого Элемент ИЗ Источник.Элементы Цикл
  ДобавляемыйЭлемент = Приемник.Элементы.Добавить(ТипЗнч(Элемент));
  ЗаполнитьЗначенияСвойств(ДобавляемыйЭлемент, Элемент);
 КонецЦикла;
КонецФункции

Tags: , скд 1с
Subscribe
promo fixin декабрь 31, 2037 16:57 1415
Buy for 30 tokens
UPD: Друзья, в августе 2019 года блог переехал на http://fixinchik.ru. Welcome! Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект "…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 87 comments