fixin (fixin) wrote,
fixin
fixin

Category:

О логике начинающих 1сников



Вот вы говорите, что 1С - это просто. Казалось бы, действительно, SQL + Basic, чего тут может быть сложного.


Дал своему помощнику, начинающему 1с-нику задачу.


В этом участке кода мог дублироваться серийный номер:


Если НЕ ЗначениеЗаполнено(СерийныйНомер)
  СерийныйНомер = СоздатьСерийныйНомер(Товар, НаименованиеСерийногоНомера);
КонецЕсли;




Попросил перед созданием серийника проверять, если есть уже серийник с таким названием, чтобы защититься от создания дублей. Вдаваться в логику работы кода было некогда (может это связано с параллельностью работы, может пользователи тупят), но такое бы решение надежно защитило от дублей.


Я видел решение этой проблемы таким:


Если НЕ ЗначениеЗаполнено(СерийныйНомер)
  СерийныйНомер = НайтиСерийныйНомерПоНаименованию(Товар, НаименованиеСерийногоНомера);
КонецЕсли;
Если НЕ ЗначениеЗаполнено(СерийныйНомер)
  СерийныйНомер = СоздатьСерийныйНомер(Товар, НаименованиеСерийногоНомера);
КонецЕсли;


Программист написал мне так:


Если НЕ ЗначениеЗаполнено(СерийныйНомер)
  СерийныйНомер = НайтиСерийныйНомерПоСсылке(Товар, СерийныйНомер);
КонецЕсли;
Если НЕ ЗначениеЗаполнено(СерийныйНомер)
  СерийныйНомер = СоздатьСерийныйНомер(Товар, НаименованиеСерийногоНомера);
КонецЕсли;


Причем в функции НайтиСерийныйНомерПоСсылке он искал ссылку по наименованию, т.е. по сути возвращал именно СерийныйНомер, но т.к. он был пустым, то ничего не находил и защиты от дублей не было. Хорошо, что посмотрел код. ;-)


А вы говорите "Бейсик - это просто". Ага, щас. Только опыт, сын ошибок трудных, дает нам право называться Программистом с большой буквы П.


 

Tags:
Subscribe
promo fixin december 31, 2037 16:57 1417
Buy for 30 tokens
UPD: Друзья, в августе 2019 года блог переехал на http://fixinchik.ru. Welcome! Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект "…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 73 comments
Previous
← Ctrl ← Alt
Next
Ctrl → Alt →
Previous
← Ctrl ← Alt
Next
Ctrl → Alt →