fixin (fixin) wrote,
fixin
fixin

Category:

Программистам: функция пересечения отрезков

Столкнулся недавно с простой задачей - есть два отрезка на прямой, заданные левой (А) и правой координатой (Б). Нужно вычислить их пересечение, если оно есть.

Код по решениею этой задачи оказался настолько простой и красивый, что я предлагаю вам попробовать ее решить, а потом выложу своё элегантное решение.


Функция ПересечениеОтрезков(А1, Б1, А2, Б2) Экспорт
//Пересечение отрезков на прямой
//А1, Б1 - левая и правая граница первого отрезка
//А2, Б2 - левая и правая граница второго отрезка
//Возвращает структуру с полями:
// Есть, если отрезки пересекаются иначе ложь
// А, Б - левая и правая гранца отрезка пересечения
Р = Новый Структура("Есть, А, Б", ложь, Неопределено, Неопределено);
Если А2 < А1 Тогда
Возврат ПересечениеОтрезков(А2, Б2, А1, Б1);
КонецЕсли;
//Здесь второй отрезок всегда правее левого на оси
Если А2 > Б1 Тогда
Возврат Р; //Пересечения нет
КонецЕсли;
Р.Есть = истина;
Р.А = А2;
Р.Б = Мин(Б1, Б2); //Минимальная из правых границ
Возврат Р;
КонецФункции

Tags: гуру-тест 1с
Subscribe
promo fixin december 31, 2037 16:57 1417
Buy for 30 tokens
UPD: Друзья, в августе 2019 года блог переехал на http://fixinchik.ru. Welcome! Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект "…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 74 comments
Previous
← Ctrl ← Alt
Next
Ctrl → Alt →
Previous
← Ctrl ← Alt
Next
Ctrl → Alt →