fixin (fixin) wrote,
fixin
fixin

Ручной способ получить список реквизитов справочников

Была поставлена задача расписать реквизиты справочника договоров и контрагентов в двух базах, написать соответствия между ними.
Для начала нужно было получить реквизиты и их синонимы из обеих баз.
Можно было бы написать обработку, которая выводила бы данные по метаданным.
Но я поступил проще и все сделал в Экселе.
Выгрузил файл описания в Эксель.


 
Убрал объединение с ячеек.
Во вторую и третью колонку поставил формулы соответственно:
=ЕСЛИ(ЛЕВСИМВ(D2;4)="Имя:";D1;ЕСЛИ(ЛЕВСИМВ(E2;4)="Имя:";E1;""))
=ЕСЛИ(ЛЕВСИМВ(D2;4)="Имя:";ПСТР(D3;10;1000);ЕСЛИ(ЛЕВСИМВ(E2;4)="Имя:";ПСТР(E3;10;1000);""))
Формула с двумя если, т.к. реквизиты табличных частей располагаются с дополнительным отступом.
На выходе получили во второй и третьей колонке название реквизита и его синоним.
В первую колонку поставил название первой или второй базы, после сортировки получилось так:
После этого выгрузил на новый лист только значения, без формул и  отсортировал по второй колонке.
Получился список реквизитов из двух баз:


Дальше осталось с помощью автофильтра убрать строки, содержащие .Формы., .Команды., .Макеты..

Чем бы кодер не маялся, лишь бы не программировать, гыгыгы...

Tags: , Опыт Excel
Subscribe

Posts from This Journal “1С” Tag

promo analitic 11:32, yesterday 37
Buy for 40 tokens
“Я выбираю свободу”, - сказал себе однажды московский журналист Александр Орлов, и уехал в Прагу. Именно там находится штаб-квартира известной еще со времен “Холодной войны” радиостанции, которая с тех пор превратилась в огромный медиа-холдинг с аудиторией сильно больше, чем население одной…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 12 comments