fixin (fixin) wrote,
fixin
fixin

Перемещение по строкам документа

Перемещение на предыдущую-следующую строку в 1С УФ.

Казалось бы, реализация таких простых кнопок, как переход к предыщей/следующей строке в списке табличной части обработки потребовало в управляемых формах много времени, чтобы разобраться.
 

Решение заключалось в вызове метода ПолучитьИдентификатор.

В итоге получился код:


&НаКлиенте
Процедура СледующаяСтрокаМатериалов(Команда)
 
ПереместитьСтрокуМатериалов(1);
КонецПроцедуры

&НаКлиенте
Процедура ПредыдущаяСтрокаМатериалов(Команда)
 
ПереместитьСтрокуМатериалов(-1);
КонецПроцедуры

&НаКлиенте
Процедура ПереместитьСтрокуМатериалов(Направление)
 Если
Элементы.ТЗМатериалы.ТекущиеДанные = Неопределено  Тогда
  Возврат;
 КонецЕсли;

 
ТекНомерСтроки = Элементы.ТЗМатериалы.ТекущиеДанные.НомерСтроки;
 Если
ТекНомерСтроки = Объект.ТЗМатериалы.Количество() И Направление = 1 Тогда
  Возврат;
 КонецЕсли;
 Если
ТекНомерСтроки = 1 И Направление = -1 Тогда
  Возврат;
 КонецЕсли;

 
СледующаяСтрока = Объект.ТЗМатериалы[ТекНомерСтроки - 1 + Направление];

 
Элементы.ТЗМатериалы.ТекущаяСтрока = СледующаяСтрока.ПолучитьИдентификатор(); //СледующаяСтрока;//Объект.ТЗМатериалы.Индекс(СледующаяСтрока);
КонецПроцедуры


 

Tags:
Subscribe

Posts from This Journal “1С” Tag

promo analitic 11:32, yesterday 37
Buy for 40 tokens
“Я выбираю свободу”, - сказал себе однажды московский журналист Александр Орлов, и уехал в Прагу. Именно там находится штаб-квартира известной еще со времен “Холодной войны” радиостанции, которая с тех пор превратилась в огромный медиа-холдинг с аудиторией сильно больше, чем население одной…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 43 comments