fixin (fixin) wrote,
fixin
fixin

Допил универсального редактора реквизитов

Давно использую Универсальный редактор реквизитов версии 2.1 от Организации Неизбежности Светлого Будущего http://onsb.org. Он работает для обычных и управляемых форм. Но, к сожалению,  он не умеет менять реквизиты адресации задач. Пришлось его допилить, чтобы мог. Правки делал для управляемой формы, потому что использовал для конфигурации «1С: Документооборот».

Когда заполняется список реквизитов, добавил:


 ДобавитьРеквизитыНаФорму(МассивРеквизитов, "ОбщиеРеквизиты");
 
ДобавитьРеквизитыНаФорму(мдОбъекта.СтандартныеРеквизиты, "СтандартныеРеквизиты");

 
//Осипов - для реквизитов адресации
 
Если Метаданные.Задачи.Индекс(мдОбъекта) >= 0 Тогда
 
ДобавитьРеквизитыНаФорму(мдОбъекта.РеквизитыАдресации, "СтандартныеРеквизиты");
 КонецЕсли;

И когда данные переносятся из формы в объект, добавил:


 //Осипов - для реквизитов адресации
 
Если Метаданные.Задачи.Индекс(мдОбъекта) >= 0 Тогда

  Для Каждого
мдРеквизита из мдОбъекта.РеквизитыАдресации Цикл
   Если НЕ (
мдРеквизита.Имя = "Ссылка" или мдРеквизита.Имя = "Ref" ИЛИ мдРеквизита.Имя = "Предопределенный" или мдРеквизита.Имя = "Predefined"
   
ИЛИ мдРеквизита.Имя = "Проведен" ИЛИ мдРеквизита.Имя = "Posted" ИЛИ мдРеквизита.Имя = "ЭтоГруппа"  ИЛИ мдРеквизита.Имя = "IsFolder") Тогда
   
ВыбОбъект[мдРеквизита.Имя] = ЭтаФорма["lyay" + мдРеквизита.Имя];
   КонецЕсли;
  КонецЦикла;

 КонецЕсли;

Обратите внимание, что РеквизитыАдресации есть только у задач, поэтому делается проверка на их существование.

Tags:
Subscribe

Posts from This Journal “1С” Tag

  • Как обмануть макет 1с?

    В 1С можно менять макеты в режиме 1с Предприятия. Но 1с-овцы не подумали, что пользователи не захотят видеть некоторые поля. Если просто удалить…

  • Корректировка регистра на 80 документов

    Мне прислали список из 80 документов, суммы которых нужно было внести в УПП в документ корректировки записей регистров для того, чтобы закрыть…

  • Ручной способ получить список реквизитов справочников

    Была поставлена задача расписать реквизиты справочника договоров и контрагентов в двух базах, написать соответствия между ними. Для начала нужно…

  • Открытие файла с нужным именем

    Небольшой гуру-тест. При сохранении файла в базу 1С сохраняется его первоначальное имя, например «Договор ННН.PDF». Задача – при открытии файла из…

  • Перемещение по строкам документа

    Перемещение на предыдущую-следующую строку в 1С УФ. Казалось бы, реализация таких простых кнопок, как переход к предыщей/следующей строке в списке…

  • Гипер-рефакторинг силами Гения 1С

    У клиента, к которому я пришел делать доработки по бизнес-процессам на УПП, вскрылось, что архитектура изуродована множественными копипастами, на…

  • Хитрый двухуровневый кэш

    Как вам такой хитрый двухуровневый кэш? Первый уровень – ДатаПотребности, второй – Номенклатура, на третьем – массив Заказов. Искать можно без учета…

  • Косячок с областями 1С

    Мне нужно было разукрашивать ячейку в четвертой колонке строки, по определенному условию, в красный цвет. Код был такой: Область = Макет…

  • Парадокс: Читаемость кода за счет лишних прогонов

    У меня был вот такой код, где выполнялось по выбору пользователя N обработок. И в конце нужно было выдать пользователю подтверждение, какие…

promo fixin december 28, 2020 16:57 1379
Buy for 30 tokens
Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект " Секс за Ваши". Если вы хотите написать пост обо мне или почитать, что пишут…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 20 comments