fixin (fixin) wrote,
fixin
fixin

Рубим лесенки из Если

Допустим есть код вида:

Если А Тогда КодА
Если Б Тогда КодБ
Если В Тогда КодВ
Иначе КодНеВ
КонецЕсли
Иначе КодНеБ
КонецЕсли
Иначе КодНеА
КонецЕсли

Это называется "условный оператор из ада".

Как заменить его на адекватный, читаемый код? Ответ под катом.

Пока Истина Цикл
Если А Тогда КодА;
Иначе КодНеА; Прервать; Конец
Если Б Тогда КодБ;
Иначе КодНеБ; Прервать; Конец
Если В Тогда КодВ;
Иначе КодНеВ; Прервать; Конец
Прервать;
КонецЦикла

Если вынести условный оператор в процедуру, то вместо Прервать можно использовать Возврат.
Tags: , ручки
Subscribe

Posts from This Journal “1с” Tag

  • Гуру-тест: СКД в ограниченных правах

    Что-то я недавно неплохо прошарился в правах доступа на СКД в 1с. Угробил 8 часов клиента и все же нашел изящное решение. Проверим, сообразите ли…

  • 14 часов на работе

    Идет горячая пора у 1сников и бухгалтеров - сдача ндс. Вчера 14 часов провел на работе. Но пахать пришлось интенсивно, так что на усталость не…

  • Обещанная статья про управляемые формы

    Читаем, улыбаемся и машем лайкаем! https://infostart.ru/public/383065/ Теперь мне все понятно про управляемый интерфейс, делюсь этим…

  • Не дают отдыхать. ;-)

    Только я собрался побакланить, как позвонил знакомый и попросил помочь с отчетиком, типо работы на час-два, бюджет 2000 р. Ндык, залез по удаленному…

  • Добавил звуковое извещение

    Теперь если нужно ввести капчу, каждые 5 секунд раздается системный сигнал. Очень удобно - не надо следить за экраном обработки по рассылке сообщений…

  • Крестовый поход на Мамбу

    Можно считать, что я освоил эмуляцию действий пользователя в браузере на языке 1с. Первая попытка была запостить автоматически (программно) записи в…

promo analitic 11:32, вчера 37
Buy for 40 tokens
“Я выбираю свободу”, - сказал себе однажды московский журналист Александр Орлов, и уехал в Прагу. Именно там находится штаб-квартира известной еще со времен “Холодной войны” радиостанции, которая с тех пор превратилась в огромный медиа-холдинг с аудиторией сильно больше, чем население одной…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 160 comments
Previous
← Ctrl ← Alt
Next
Ctrl → Alt →
Previous
← Ctrl ← Alt
Next
Ctrl → Alt →