fixin (fixin) wrote,
fixin
fixin

Схема запроса

В новых релизах 1С8 появился объект схема запроса. С ним сопровождать типовые конфигурации стало еще удобнее.

Если нужно хирургически вмешаться в запрос, теперь не требуется вручную разбирать текст запроса, можно загрузить его в схему, программно добавить нужные изменения и собрать обратно в текст из схемы.

Удобно, даже я использовал на практике для добавления отбора по ответственному в одном из типовых отчетов:


Процедура ДобавитьФильтрПоОтветственному(Запрос, ВыражениеПоля);
 
//РИТ Осипов 2017-02-16
 //Чтобы работал отбор по ответственному
 
Если ЗначениеЗаполнено(ВыбОтветственный) Тогда
 
СЗ = Новый СхемаЗапроса();
 
СЗ.УстановитьТекстЗапроса(Запрос.Текст);
  Для Каждого
ТекСхема ИЗ СЗ.ПакетЗапросов Цикл
   Для Каждого
ТекОператор ИЗ ТекСхема.Операторы Цикл
   
ТекОтбор = ТекОператор.Отбор;
   
ТекОтбор.Добавить(ВыражениеПоля + ".Ответственный = &Ответственный");
   КонецЦикла;
  
//ТекОтбор.Добавить();
 
КонецЦикла;
 
Запрос.Текст = СЗ.ПолучитьТекстЗапроса();
 
Запрос.УстановитьПараметр("Ответственный", ВыбОтветственный);
 КонецЕсли;
КонецПроцедуры


Tags:
Subscribe

Posts from This Journal “1С” Tag

  • 1С и искусственные серверные барьеры

    Заметил, что в управляемых формах 1С принуждает программистов к плохой архитектуре решений. Вкратце упомяну, что теперь большинство внешних…

  • Особенности белорусского Налогоплательщика

    Взял подработку у одного знакомого чувака из Беларуси. Платил мало (я то беру 1500 в час, а там по 800), но знакомый хороший, грех было отказывать,…

  • 1С отрицает очевидное

    Работаю с флагманом 1С, конфигурацией ERP. Вижу, что 1С прошило всю конфигурацию обращениями к модулям, где разработчик, внедряющий 1С может…

  • Как обмануть макет 1с?

    В 1С можно менять макеты в режиме 1с Предприятия. Но 1с-овцы не подумали, что пользователи не захотят видеть некоторые поля. Если просто удалить…

  • Корректировка регистра на 80 документов

    Мне прислали список из 80 документов, суммы которых нужно было внести в УПП в документ корректировки записей регистров для того, чтобы закрыть…

  • Ручной способ получить список реквизитов справочников

    Была поставлена задача расписать реквизиты справочника договоров и контрагентов в двух базах, написать соответствия между ними. Для начала нужно…

  • Открытие файла с нужным именем

    Небольшой гуру-тест. При сохранении файла в базу 1С сохраняется его первоначальное имя, например «Договор ННН.PDF». Задача – при открытии файла из…

  • Перемещение по строкам документа

    Перемещение на предыдущую-следующую строку в 1С УФ. Казалось бы, реализация таких простых кнопок, как переход к предыщей/следующей строке в списке…

  • Гипер-рефакторинг силами Гения 1С

    У клиента, к которому я пришел делать доработки по бизнес-процессам на УПП, вскрылось, что архитектура изуродована множественными копипастами, на…

promo fixin декабрь 28, 2020 16:57 1379
Buy for 30 tokens
Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект " Секс за Ваши". Если вы хотите написать пост обо мне или почитать, что пишут…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 15 comments