fixin (fixin) wrote,
fixin
fixin

Схема запроса

В новых релизах 1С8 появился объект схема запроса. С ним сопровождать типовые конфигурации стало еще удобнее.

Если нужно хирургически вмешаться в запрос, теперь не требуется вручную разбирать текст запроса, можно загрузить его в схему, программно добавить нужные изменения и собрать обратно в текст из схемы.

Удобно, даже я использовал на практике для добавления отбора по ответственному в одном из типовых отчетов:


Процедура ДобавитьФильтрПоОтветственному(Запрос, ВыражениеПоля);
 
//РИТ Осипов 2017-02-16
 //Чтобы работал отбор по ответственному
 
Если ЗначениеЗаполнено(ВыбОтветственный) Тогда
 
СЗ = Новый СхемаЗапроса();
 
СЗ.УстановитьТекстЗапроса(Запрос.Текст);
  Для Каждого
ТекСхема ИЗ СЗ.ПакетЗапросов Цикл
   Для Каждого
ТекОператор ИЗ ТекСхема.Операторы Цикл
   
ТекОтбор = ТекОператор.Отбор;
   
ТекОтбор.Добавить(ВыражениеПоля + ".Ответственный = &Ответственный");
   КонецЦикла;
  
//ТекОтбор.Добавить();
 
КонецЦикла;
 
Запрос.Текст = СЗ.ПолучитьТекстЗапроса();
 
Запрос.УстановитьПараметр("Ответственный", ВыбОтветственный);
 КонецЕсли;
КонецПроцедуры


Tags:
Subscribe

Posts from This Journal “1С” Tag

  • Добавление вместо изменения

    По возможности при обновлениях типовых конфигураций нужно использовать добавление вместо изменения исходного кода. Вот в этом примере можно было бы…

  • Ну как же ж можно, 1С?

    Иногда в типовом коде встречаются такие ляпы, что ну просто стыдно. Вот отлаживал для 77 обработку обслуживания популярного фискального регистратора…

  • Доступность меню "Операции"

    УФ портят человека. Возник вопрос, как сделать пользователю ЗУП 2.5 сделать доступными меню операции. Поковырялся в правах, нашел право "Меню Все…

  • Хайдинг заголовка в 1С.

    Началось все немного с другого конца. Пользователь пожаловался, что отчет печатается мелко. Начал смотреть - включен автомасштаб, а справа выводится…

  • В заботе о тех, кто придет после нас!

    Чтобы те, кто будут обновлять после нас, заметили важные нюансы, я оставляю общй модуль с КРИЧАЩИМ названием. Почитают, вникнут! Не забудут!

  • Заказчика мучает совесть, но он держится

    Вот один мой заказчик-должник уже больше года должен 13 625 рублей. Я уж и забил на этот долг, так, раз в квартал напоминаю, благо отношения…

  • 1С и котики

    Базовая 1С обновляется так: Заметили котика?

  • Что знает программист 1С

    Ходит расхожее мнение, что программист 1С - это не программист, а так, писатель скриптов. Что любой выпускник технаря будет успешным в 1С, это, мол,…

  • 1С: Поле "Орыгинал"

    Делюсь кодом, как можно добавить на форму списка колонку флажка из связанного с документом регистра сведений. На примере вывода флажка, что поступил…

promo fixin december 28, 2020 16:57 1343
Buy for 30 tokens
Добро пожаловать в журнал Осипова Сергея Александровича, известного также как Fixin и Гений 1С. Рекомендую ознакомиться с Часто Задаваемыми Вопросами обо мне. Что я хочу в подарок - список. Мой проект " Секс за Ваши". Если вы хотите написать пост обо мне или почитать, что пишут…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 16 comments