fixin (fixin) wrote,
fixin
fixin

Схема запроса

В новых релизах 1С8 появился объект схема запроса. С ним сопровождать типовые конфигурации стало еще удобнее.

Если нужно хирургически вмешаться в запрос, теперь не требуется вручную разбирать текст запроса, можно загрузить его в схему, программно добавить нужные изменения и собрать обратно в текст из схемы.

Удобно, даже я использовал на практике для добавления отбора по ответственному в одном из типовых отчетов:


Процедура ДобавитьФильтрПоОтветственному(Запрос, ВыражениеПоля);
 
//РИТ Осипов 2017-02-16
 //Чтобы работал отбор по ответственному
 
Если ЗначениеЗаполнено(ВыбОтветственный) Тогда
 
СЗ = Новый СхемаЗапроса();
 
СЗ.УстановитьТекстЗапроса(Запрос.Текст);
  Для Каждого
ТекСхема ИЗ СЗ.ПакетЗапросов Цикл
   Для Каждого
ТекОператор ИЗ ТекСхема.Операторы Цикл
   
ТекОтбор = ТекОператор.Отбор;
   
ТекОтбор.Добавить(ВыражениеПоля + ".Ответственный = &Ответственный");
   КонецЦикла;
  
//ТекОтбор.Добавить();
 
КонецЦикла;
 
Запрос.Текст = СЗ.ПолучитьТекстЗапроса();
 
Запрос.УстановитьПараметр("Ответственный", ВыбОтветственный);
 КонецЕсли;
КонецПроцедуры


Tags:
Subscribe

Posts from This Journal “1С” Tag

Buy for 70 tokens
Слаб душой человек, ой слаб. Зарекался я в этом году даже не думать про зимний Таиланд. Действительно, ну сколько можно? И главное - зачем? Много предыдущих лет такой вопрос даже не мог возникнуть. В декабре-феврале ты должен купаться в океане, есть свежие креветосы, путешествовать и…
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 15 comments